OSSEC – Error: PostgreSQL client libraries not installed.

I was playing with OSSEC HIDS this afternoon and trying to get it configured to work with MySQL and when I was running make on the DB setup I was getting this error:

Error: PostgreSQL client libraries not installed.

I was a bit frustrated with it, it seems as it if requires both MySQL and PostgreSQL to be installed to finish compiling. To get around this just install PostgreSQL that seems to do the trick.

# yum install postgresql

Running the main package seems to do the trick. Then try running setdb again:

# make setdb

If you prefer not to install PostgreSQL then you could try the instructions here: https://groups.google.com/forum/?fromgroups=#!topic/ossec-list/3BwJ2wxKAWo.

Hope this helps someone, I am sharing it because I had a challenge getting past it and found very little info out there on how to fix it.

Cheers